Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 28, 2025 - 03:00 MDT
Scheduled
Hello All, We are applying emergency patches as part of our ongoing efforts to safeguard your data and maintain the integrity of our hosting environment. Maintenance Window Sunday, September 28, 2025 - 4:00 AM – 6:00 AM CDT Impact: VPN tunnels and Cisco VPN client connections will be unavailable during this window. During this period, some services may be briefly unavailable. We recognize that downtime can be disruptive, but addressing this vulnerability promptly is critical. Acting now prevents potential compromise and ensures our security posture remains strong.
Your trust and security are our highest priorities, and we are taking decisive steps to protect both.
Thank you for your understanding as we complete this urgent maintenance.
Posted Sep 26, 2025 - 10:17 MDT
This scheduled maintenance affected: Infrastructure.